General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Good Day to all Porsche enthusiasts...

  #1  
Old 06-28-2008, 12:52 PM
Thread Starter
Join Date: Jun 2008
Posts: 2
Default Good Day to all Porsche enthusiasts...

I recently purchased a '75 Targa, very nice body on it, with an '83 3.0 ltr. engine that had a bad ignition module... after trying an MSD I finally received a permatune which works well. Now that I finally got the engine running, it doesn't just smoke, it makes fog as if I was spraying for mosquitos! I drained all the oil and replaced 8 quarts but it smokes like crazy after running for a minute. Can anyone enlighten me as to the problem or remedy? I was ssooo looking forward to driving this 911 as I took a 10 year break from them but not by choice... life is what happens as your busy making plans... and that's what happened. Anyway, I liked to resolve this problem as it would be an injustice to all Porsches to have it seen on the streets as is, not to mention embarrassing for both of us. Any suggestions. (780) 443-1112 Also posted in new members area.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
alex.from.spec
Off Topic
0
12-14-2013 07:47 PM
Oskar
New Members Area
1
07-07-2008 02:21 PM
joff931
New Members Area
0
11-07-2007 05:48 PM
germancarlover
New Members Area
1
12-29-2005 08:43 PM


Thread Tools
Search this Thread
Quick Reply: Good Day to all Porsche enthusiasts...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.